Spectre v4: así sigue afectando esta vulnerabilidad a los procesadores Intel, AMD y ARM

Escrito por Juan Diego de Usera

De nuevo, otra variante más de Spectre ha sido descubierta por parte de investigadores. Spectre v4 es la nueva vulnerabilidad, que afecta a la característica del almacenamiento especulativo que utilizan los procesadores tanto de AMD, ARM, e Intel. Esto significa que muy pronto habrá otra oleada de parches por parte de estas empresas para intentar solucionarla.

Definitivamente, el año 2018 está siendo el año de las vulnerabilidades en procesadores. Y, de estas, la más persistente está siendo Spectre. No porque esté siendo especialmente complicada de eliminar, sino porque cada vez aparecen más variantes de este tipo de vulnerabilidad. Lo peor de todo, es que esta variante afecta de manera conjunta a los procesadores tanto de AMD, como de ARM e Intel, dado que afecta a una característica que comparten los tres tipos de arquitecturas: el buffer de almacenamiento especulativo.

La variante Spectre v4 es capaz de ser ejecutada en remoto desde un navegador que esté infectado con código malicioso, y desde el que un posible atacante es capaz de poder acceder a datos sensibles, dado que la vulnerabilidad le permite acceder al buffer de almacenamiento especulativo, a la vez que hace creer al procesador que este está leyendo desde una parte diferente de su interior. El resultado es que, de esta manera, el atacante puede tener acceso a información muy sensible, como direcciones de correo electrónico, contraseñas o números de tarjetas de crédito.

Spectre v4 no ha sido empleado nunca, pero ha de ser corregida

El buffer de almacenamiento especulativo al que afecta Spectre v4 es una parte común de los procesadores de AMD, ARM e Intel donde el procesador almacena datos para comprobarlos antes de escribirlos a sus direcciones de memoria correspondientes. Es en este buffer donde se comprueban estos datos y si la dirección de memoria que se le había asignado tentativamente es la correcta. En caso afirmativo, se escriben. Pero, en caso negativo, la instrucción se deshecha.

La nueva vulnerabilidad Spectre v4 ha sido descubierta por investigadores de Google y de Microsoft. Especialmente los últimos han confirmado que es un tipo de vulnerabilidad que nunca ha sido utilizada por un atacante. Al menos, los investigadores de Microsoft no tienen registro de que se haya producido este tipo de ataque, por el momento. En cualquier caso, todos los fabricantes de procesadores han emitido los correspondientes boletines de alerta.

Tanto AMD como Intel han afirmado que están desarrollando parches para sus nuevos procesadores, y suponemos que tanto ARM como IBM también lo están haciendo. Mientras tanto, Microsoft debería de lanzar una nueva oleada de actualizaciones de su Sistema Operativo, a la vez que (suponemos) Google también debiera hacerlo para Android. Apple no creemos que vaya a ir muy por detrás con los nuevos parches para MacOS e iOS.

Fuente > Bleeping Computer

Continúa leyendo
  • linkin

    ¿No podemos hacer una demanda colectiva o algo? Esto ya es inaceptable…¿otra bajada de rendimiento? Al final mi 6600 va a ser un core 2 duo…

  • Aisaka Taiga

    Si continuan buscando bugs, no descarto que salga Spectre V5.